
Project Spaces, Projects and Workspaces

Project spaces store sets of projects. Before a project can be made, a
project space has to be set up. Project spaces allow multiple projects to be
displayed at a time. If an existing project is opened without an existing
project space, a project space is created automatically to house 
the project.

A project, at a minimum, is a list of files that you find it useful to group
together logically. A project must be part of a project space. 

Creating a project facilitates operating on the files
in the project as a group, whether using version
control, creating a "Tags" database, or just loading
files.  The files within the project may be further
divided into Workspaces, which may contain
project and non-project files. 

Within a project you can create a Workspace, in
which you define the files that are open. So this
helps you to focus on those parts of your project
that you think are important.

You can think of each workspace almost as a
separate instance of the EDE.  That is, when you
change workspaces you have the ability to pick up
where you left off with a group of files.  It doesn't
matter if you worked on that group of files a half-
hour before or three months ago.  It is as if an
instance of the EDE were frozen in time containing
these files.

A workspace differs from a project in that it does not store the system-wide
options normally stored in a configuration file. Only the transient options
and settings are saved as part of the workspace. It retains information about
the currently open windows and documents. Other state information is
stored as part of the project.

F1 Help!

There are many resources included in the package with additional information
on the compiler, the EDE/editor, the debugger, etc. The documentation is
available as HTML, PDF or Windows Help files . Each format has its own
advantages, but the beauty of the Help files is that you can press the F1 key
anywhere in your code and when the help system recognizes the (key) word
under your cursor, it will prompt you with a list of the manuals where it has

Using Advanced Features of the 
Embedded Development Environment

This document contains an overview of some of the more unique and helpful features available within the Embedded
Development Environment (EDE). These advanced features demonstrate to you the power and versatility of the TASKING
Software Development Tools. 

Please be aware that the EDE user interface differs from product to product, so the menus may be presented in a different way.

Of course our manuals extensively describe all features of the EDE and the compiler tools.
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found references to this keyword. A few clicks will then bring you quickly to
the right spot in the documentation.

Switching Compilers

Are you involved in more than just one embedded development project and
using more than one single software development toolset? From within
EDE (Project > Select Toolchain > Scan Disk) you can scan your
workstation for other TASKING toolsets and instantly switch over from one
toolset to the other. This is not only very productive when for instance you
want to switch from M16C to C166/ST10, but also if you want to switch
from your current project that uses the latest TASKING compiler, to your
previous project that needs a minor modification and for which you used an
older version of the compiler.

Tool Options

Being a command-line tool die-
hard (hey, nothing's wrong with
that!!), you may want to use the
TASKING tools without the
EDE/editor. Or you might have
your own well-beloved editing
environment that you feel
comfortable with. No problem at
all! The TASKING tools can be fully
manipulated from the command
line, and the documentation gives
you a full overview of the options
to be used. As a matter of fact,
from within EDE you can even see
which options are passed on to the
compiler and assembler/linker.
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Automatic Generation of Startup Code

Of every embedded application the run time environment
needs to be specified in the application's startup code. The
TASKING EDE will automatically generate the startup code
and save you from this tedious task. The file
<project>_cstart.asm will be generated in the project
directory and will also be added automatically to the
project. Both generation as well as addition of the startup
code file to the project can be switched on and off under
Project > Project Options > Processor > Startup Code.

Output Formats

Upon completion of your embedded application you
can have output files for different purposes be
generated. In case you want to validate or debug your
code, you can use the IEEE-695 formats. IEEE-695 is
the format that the TASKING CrossView Pro debugger
uses, but it is also the preferred format for all leading
third party in-circuit emulators. For burning you code
into an EPROM you may want to use the S-Rec or
HEX formats.

Splitting Windows

Instead of having one view on your source code file,
you can manipulate the EDE windows in a way that you
have two or even four different views on one single
open file. You can enter data in any of the open views
and by using the scroll bars you can reposition the views independently of
each other. To split your source windows you simply pull one of the markers
in the vertical or horizontal scroll bars. 

By default the horizontal scroll bar is not activated, but you can quickly change
that by right-clicking in the windows, then selecting Properties > Window >

Horizontal Scroll Bar. When you have done this, you will see the split
window marker to the left of the scroll bar.
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Viewing HTML files, browsing the web

In EDE you can not only view
an HTML formatted file, but
you can even open a window
and have it act as a browser.
You can open HTML files on
your local hard drive, or surf the
web and browse through the
TASKING Technical Support
Pages for example. The
screenshot above shows you
the HTML version of the
compiler manual in a small
window and the larger window
in the background presents the
M16C FAQ list on our web site.
So everything at hand, in one
seamless environment, to
develop your embedded
projects.

To enable the HTML viewer and
web browser you need to make
some new settings in EDE:
From the menu, go to:
Customize > Libraries. Here
you can add extra functionality
to EDE such as an FTP file
transfer utility or an extended
Clipboard viewer. Make sure that you select the HTML WYSIWYG

Editor/Viewer in the CodeWright Libraries Section at the top, and add the file
CWIEXPLR.DLL in the User Defined Libraries section in the middle. This DLL
file can be found in the \bin directory of your tools installation. Once you
have made these additional settings you can open an HTML file and an
additional browse window will open automatically.

CodeSense - Automatic Word Completion

CodeSense uses tooltips and drop-down lists to complete the names of
symbols (member lists, parameters, function definitions, and other source
code elements). Go-to buttons are also available that allow you to quickly
browse for symbols and symbol definitions. CodeSense information can be
obtained from source code in the current open file, the current project, or
from source code files
in custom-specified
CodeSense libraries.
CodeSense hover
tooltips and drop-down
lists will display
automatically at appropriate times while editing, or with the
press of a keystroke. To test this productive feature yourself,
you can start inserting one of the recordvar structure
members in the sim sample project provided with the
package. Upon typing the dot, EDE will prompt you with a
dropdown list of all members from which you can select the
one you need.
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Source and Project Navigation

EDE offers you many ways to navigate through your project and source
code. The project toolbar at the left side of your screen opens by default in
the Project Management view, but through the tabs at the bottom you can
open for example the Bookmark Manager, the Outline Window, the
CodeFolio Manager or the Object Browser. The latter gives you not only
an overview of all objects (variables, functions, defines, etc.) in your source
file, but by selecting an object the focus of the source window instantly
goes to the spot where the object is defined.

As an exercise you may type "r*" or "*" in the identifier entry field at the top,
while you have the file demo.c of the sim project open. The result should
be equal or similar to the screenshot on the
right.

CodeFolio - a.k.a. Code Snippets

To help you using your company's standard
templates for source code and source files,
EDE offers you the CodeFolio feature.
CodeFolio manages your templates and
frequently used pieces of personal code (also
known as snippets.) You can create a snippet
by selecting a part of your code and drag it into
the CodeFolio manager, where you can drop
it in the directory of your choice. Once you
have created a collection of snippets (we
provided a few standard templates with the
package) you can double-click a snippet to
have it inserted at the cursor position in the
open source file.

CodeFolio snippets may be extended with
special CodeFolio macros; CodeFolio macros
will automatically expand the current date and
time, move the cursor to a specific location,
perform mathematical equations, and more.

Selective Display, Collapse/Expand code

From the Text > Selective Display menu you have many options to gain a
better overview of your source code. In the graphic the Multi-level option
is used, which let your functions collapse at the braces level. Clicking on the
(+) or (-) in the left column will expand, respectively collapsing your code.
This is just one of the six formatting options to help you keeping the right
focus on your code.
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MISRA C Support

Are you concerned about the quality of your code or the
reliability of the application that you develop? Does your
product have to comply with safety related standards?
Many TASKING compilers (including 8051, XA, M16C,
C166/ST10, TriCore and StarCore) offer support for the
MISRA C guidelines through the MISRA C options from
the Project > Project Options > C Compiler > MISRA C

menu. The Motor Industry Software Reliability Association
(MISRA) is a consortium of companies that developed
guidelines on which TASKING's MISRA C code checking is
based. The consortium's effort was in response to the UK
Safety Critical Systems Research Program, and the result
is 127 programming rules applicable when developing
safety-related applications in C.

Not every programmer is fully aware of the effects of all
the possible constructs in the C language. For instance,
the lack of type checking and the application of implicit
casts tend to cause confusion and hence errors. A
number of the features in C have not been well defined or are defined
differently from what a pro-grammer expects. You can use the TASKING
MISRA C enhanced code checking to avoid falling in the pitfalls of the C
language.

File Manager

The EDE does have a file manager integrated to navigate through the files
of your project. Maybe that doesn't sound too exiting, as there are already
many ways provided with Windows to browse your disks or network drives,
but this manager offers you some extras that particularly are of benefit in a
code development environment: You can for example Touch and Check
in/out files, add your own User functions, or define the directories that you
often visit. Give it a try! You'll like it.

And more…

A few other interesting features that you may want to try yourself:

� Right-click in a window or button bar and browse the list of 
applicable options

� The match brace facility to outline the scope of e.g. a function

� The file difference utility

� Integrate your company's source code version control system 
into EDE

� Setting local and global bookmarks

� Extend the functionality of EDE by activating libraries from the 
Customize > Libraries menu. A vast collection of additional 
libraries is available on the Internet, e.g. at 
http://www.starbase.com/support/CodeWright/AddOns
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