Getting Started with your 8051 Project

The TASKING 8051 Software Development Toolset is based on the Embedded Development Environment (EDE) that
incorporates a professional editor, project builder and debugger. From one toolbar you can compile a single file, build a project
and start the CrossView Pro debugger.

Now that you've installed the demo, here is a brief overview of the toolset that will give you some assistance getting started
with your project. If you have not already done so, we recommend that you read the Getting Started with your 8051 Demo
tutorial to get acquainted with the first steps necessary to get the 8051 toolset running.

This document also contains an overview of some of the advanced features available within the EDE. These features
demonstrate to you the power and versatility of the TASKING 8051 Software Development Toolset.

While walking through this Getting Started document you can also refer to the on-line manuals for further assistance.
The on-line manuals are available as buttons in the toolbar or via the manual selection in the EDE menu.

DEFINING THE PROJECT SPACE

So let's get started with the 8051 toolset. If you are beginning with the
development of a new application, you need to define the Project Space
that will incorporate the one or multiple Projects that are part of it. There is
a more extensive explanation on Project Spaces and Projects and how they
relate, further on in this document; for now you can just follow the next
instructions.

1. Select File > New Project Space from the menus. This will open the
Create a New Project Space dialog box.
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2. Now give your Project Space a name (for example, denp) and click OK.
The Project Properties dialog box will appear for you to identify the
Projects (new or existing) to be added. The properties will be saved in
a file, for example deno. psp

3. There are two folder icons located adjacent to the
Projects section within the Project Properties dialog
box. Click on the Add new project to project space e Sesca I o e | ]|
button which will then will open the Add New Project el el e | ok B HEs

P I weois : Project Space:  C:\dcoS1hdemao.psp

to Project Space dialog box. == ,
| Projects: @

4. Give your project a name (for example, control ) and
then click OK. A file with the name control . pjt will
be created. The Project Properties dialog box then D
appears for you to identify the files to be added.

Project Properties

™ Hide projects already in project space

— Esternal workspace:

5. Add all the files (source files, header files, text files <o = 4k
describing your application, etc.) you want to be part of
your project. If you do not have any source files yet, click
on the Add new file to project button in the Project
Properties dialog box. This will open the Add New File _Carcd | _tiop |
to Project dialog box. Now enter a new filename and
click OK. A new empty file will be created and added
to the project.
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6. If you do have the source files already, click on the Add Existing File to
Project button (third from the left) in the Project Properties dialog box.
The Select One or More Files to Add to Project dialog box opens.
Select the directory that contains the files you want to add to your
project and add the applicable files by double-clicking on them, or by

selecting them and pressing the Open button.
The new project is now open.

Select OK.

Note: EDE automatically creates a startup file (discussed later in more
detail) and a makefile for the project. EDE updates the makefile every

time you modify your project.

7. After you've defined the files that belong to your project, the next
operation is to select the target CPU you need to create your project for.
To do this, select Project > Project Options > Processor > Processor

Selections from the menu.
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The Project Options menu gives you the possibility to set
options for the compiler, assembiler, linker, formatter and the
debugger. The compiler and assembler options respond to
the active window. For example, if the active window in EDE
is a C source file, the compiler selection in the EDE menu
allows you to set options for that specific file or for all C files
in the project. The compiler's default options are set in the
related panel (as it is for the assembler and the linker), so
that you need to review, and eventually configure, the flags
according to your requirements. For further assistance,
consult the on-line manuals.
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EDE and shows you how you can use the project environment. With the
standard toolbar at the top of this window you can build this project
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8. Once the characteristics of your project have been defined in terms of
compiler settings, memory addresses, code locations, data locations
and the format of the output file to generate, you can Build it by clicking
on the Rebuild button available in the EDE toolbar.

9. After the files have been processed, the resulting messages generated
by the tools will be displayed under the Build tab in the Output section
at the bottom of the EDE window.

The generated absolute file (. abs) is now ready to be debugged with the
CrossView Pro Debugger. See the Debugging your Application with
CrossView Pro tutorial for more information.

USING ADVANCED FEATURES

Although all features of the EDE and the compiler tools are described
extensively in the manuals, we would like to highlight some of the more
unigue and helpful features in this Getting Started document.

Project Spaces, Projects and Workspaces

Project spaces store sets of projects. Before a project can
be made, a project space has to be set up. Project spaces
allow multiple projects to be displayed at a time. If an

the project. Project A

A project, at a minimum, is a list of files that you find it
useful to group together logically. A project must be part
of a project space.
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PROJECT SPACE

existing project is opened without an existing project
space, a project space is created automatically to house

Project B

PROJECT B

project as a group, whether using version control, creating
a "Tags" database, or just loading files. The files within the
project may be further divided into Workspaces, which
may contain project and non-project files.

Creating a project facilitates operating on the files in the | |

Within a project you can create a Workspace, in which you
define the files that are open. So this helps you to focus
on those parts of your project that you think are important.

You can think of each workspace almost as a separate instance of the EDE.
That is, when you change workspaces you have the ability to pick up where
you left off with a group of files. It doesn't matter if you worked on that
group of files a half-hour before or three months ago. It is as if an instance
of the EDE were frozen in time containing these files.

A workspace differs from a project in that it does not store the system-wide
options normally stored in a configuration file. Only the transient options
and settings are saved as part of the workspace. It retains information about
the currently open windows and documents. Other state information is
stored as part of the project.

Project C Project D

Workspace I: File 1 and 2 open

Workspace Il: File 1 and 3 open,
File2 open but minimized

Workspace IllI: File 2 open, File 4
open in split screen mode

3 Starti .
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F1 Help!
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There are many resources included in the package with additional information
on the compiler, the EDE/editor, the debugger, etc. The documentation is

available as HTML, PDF or Windows Help files .

Each format has its own

advantages, but the beauty of the Help files is that you can press the F1 key
anywhere in your code and when the help system recognizes the (key) word
under your cursor, it will prompt you with a list of the manuals where it has
found references to this keyword. A few clicks will then bring you quickly to
the right spot in the documentation.
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Switching Compilers

Are you involved in more than just one embedded development project and
using more than one single software development toolset? From within
EDE (Project > Select Toolchain > Scan Disk) you can scan vyour
workstation for other TASKING toolsets and instantly switch over from one
toolset to the other. This is not only very productive when you want to

switch from 8051 to
XA, but also if you
want to switch from
your current 8051
project that uses the
latest TASKING

Select Toolchain

Product Folder:
c:hprogram fileshtaskinghcbwB0r]

T oolchains:

Ok

Cancel

Ch51compiler, to your
previous project that
needs a minor
modification andfor
which you used an
older version of the
compiler.

TASKIMG CAC++ for x4 3.005

TASKIMG Tool: for 8051 »7.011
i1 M Tools for 8057 k. 011
TASKING Toolz for b wa.0 11

TaSKING CAC++ for CIBE/STI0 w7 .0N

v Display 'Toolchain switched to ' message

Browsze.

Scan Dizk...

Delete

Uy
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Tool Options

TASKING 8051 TUTORIAL

Being a command-line tool die-hard (hey, nothing's wrong with that!!), you
may want to use the TASKING tools without the EDE/editor. Or you might
have your own well-beloved editing environment that you feel comfortable
with. No problem at alll The TASKING tools can be fully manipulated from
the command line, and the documentation gives you a full overview of the

8051 Project Options [SIM_PJIT]
# Processor Optimization
=1 C Compiler DOptimization level: 1 optimization
Memony Maodel
H i s
Cf;:[::;z:a?ion Cuztom optimizations:
Dptimization | Relax aliaz checking i
Allacation v Common subexpression elimination [CSE)
Language Extensions v Constant and copy propagation [data flow)
Debug w| Produce small code (favor code size above execution speed)
Printf/Scanf | Peephole optimizer [remove redundant code)
Flaating Paint | Move invariant code outside loop
warhings (v Optimize into compound assignments
- MISRAC (| Fazt loops [mare code size)
Mizcelaneoyus (v Code order rearranging in flow optimization
- Assembler (w! Extra flow optimization pass
1+ Linker (w! Use register parameter pazzsing [(R2-R7) _vJ
[+ CrossView Pro
[+ Flazher
Opti it ——
1"${PRODDIR)Sinclude!" -Ms -l -ivo=0x0000 -Ci8051 -DAcdFhikLmpsirbw
-a20 -1 -g -wetrict -z -mid=128
ak | Cancel Defaults | Help ‘

options to be used. As a matter of fact, from within EDE you
can even see which options are passed on to the compiler

and assembler/hnker 8051 Project Options [SIM.PJT]
= Processol Startup Code
Frocessor Selection [¥ Generate startup code [<project>_cstart asm)
Automatic Generation of Startup Code . T v S
o . . aypiz:;Memw I Dicable al intermupts at startup
Of every embedded application the run time environment +-C Compiler IO L e e o i
needs to be specified in the application's startup code. e Eemel RAM gegefo be used for paged dsta Lpde) [
TASKING's EDE will automatically generate the startup code - Doniiow Pro Sel trup vaus of SYSCON (e CO0/CE0D) [
and save vyou from this tedious task. The file Sl e e LR ERE
<proj ect>_cstart.asmwill be generated in the project N
directory and will also be added automatically to the project.
Both generation as well as addition of the startup code file to
the project can be switched on and off under Project > OB
Project Options > Processor > Startup Code. o
8051 Project Dptions [SIM_PJT] J
Output Formats i o G oo oot |t |
e e A
Upon completion of your embedded application you e S I~ Etnced DMFST for st o51)

can have output files for different purposes
be generated. In case you want to validate or debug
your code, you can wuse the |EEE-695
or OMFb51 formats. IEEE-695 is the format that the
TASKING CrossView Pro debugger uses, but it is
also the preferred format for all leading third party
in-circuit emulators. For burning you code
into an EPROM you may want to use the S-Rec or
HEX formats.

Linking
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manipulate the EDE windows in a 144; unsigned int tmp; 37: #define OUTPUT LEM 35
Way that yOU have twWO or even fOUr 145: . S Char inbuf [ INPUT_LEMN] : A% input buf
B . . LR if (num < 2) SosaEchar outhuf [ OUTPUT LEN] ; £* output bu
different views on one single open 137: b e st S -
file. You can enter data in any of the 148: else 41: static rec_type recordvar = (-1, "TA
. . 149: { 42 : _rom atatic rec_type sStatrec = {87, "he
open views and by '."Ifc"lng the 8_0r0” L5 for (tmp = num--; num: hum—-T SEEH rom static char belll2] = { riggpr=
bars you can reposition the views K I— L b 4
independently of each Tk i void &
p y . 143 : char locvar = fx'; 4 an-un 160: myputs( rom char *string )
Other' TO Spllt yOUr !E- q44.: unsigned int tmp; 4 o £
source windows you ® [45: 162: char *p = outhuf:
simply pull one of the —— ke A Wiy
y . . -‘ 472 rerubis s 3k e while| *p++ = *Q—tring++ 1
markers in the vertical or JJQB: else LEE: E #]_rom char *stiing
horlzontal SCrO” bars —  EEE 1 LG _simo [ OUTPUT STREAM, outbuf, OUTPUT
i A for (tmp = nuwe—-; num? nuw——_ | AEERTD B
HE trp *= num; 168: |
By default the horizontal scroll bar 152: 1 163
is not activated, but you can quickly . B¢ Recd = iine frem mm dmput pest My
change that by right-clicking in the AR . i K | t

windows, then selecting

Properties > Window >

Horizontal Scroll Bar. \When you have done this, you will see the split
window marker to the left of the scroll bar.

Viewing HTML files, browsing the web

In EDE you can not only view
an HTML formatted ﬂ|e’ but 5l TASKING EDE [ 8051 - C:\dccS1\examples\xvwisim. pit | [_[2]x]

yOU can even Open a WIndOW File Edit Search Project Text Document Customize Tools ‘Window Help EDE
and have it act as a browser, JE 2T /BSEEY M@[o o] Jaae s EPpQILBDRE

. =
You can open HTML files on || BB 2| [Felwmwiakins conieampot/ a6 Ao Hm
yOUI’ |OCa| hard drlve, or Surf Ea asm“g“;::] (s ' Home ' About ', Products ' Support ) Resour
the web and browse through 5 banksw 2 Fies) TASKING
the TASKING Technical Support {52 i e :
Pages for example The qa scrall (5 Files) Y 32 bit % 8/16 bit % EDE ‘ FLEXIm '
4, EEEIE ae [ .
screenshot above shows you | @3 Source Fiks o : E =
H (] Header Files :
the HTI\/IL version of the R - Chapters |
i [#] Other Files 3
compiler manual n @ small | Sorir ||| R e e o e sl SRR 1 S sl
window and the |a|’ger a%éims[ﬁ FiIerI] :F:ur _— Cesa e S e g Evemew}m 1 .
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presents the 8051 FAQ list on b[] DEMO.C Report e 5. Compiler Digzmostice
our web site. So everything at i = .
P cader Files GhsgHed LhE 7. Bun-time Enwironment
hand |n one Seamless (] Resaurces factorial ([ unsigned char num )
! 51423 Other Files { :
environment, to develop your 01 READMETT o S T N T T Appendices
. [y WELCOME T un=igned int tmp; -
embedded prOJeC’[S. A Flexible License Manager (FLEm)
if (num < 2) B. Safer C
. return 1 C. 3FE Definhion File =
To enable the HTML viewer elae o I _»l_l
and web browser you need to
make Some neW Set“ngs |n i Eﬁiﬁiffﬂgr;gﬁ:}ncbuilder v6.0 rl EN00000000-027 (o) 2001 TASKING, Inc. e
. . Assenbling demo.src
EDE Frgm the _men_U' go to Assembun; addone. src
Customize > Libraries. Here e o Macro preprocessing sin_cstart. asu
- - Azsemhling sim csStart.src -
you can add extra functionality = s
EDE h FTP f| | 't:IQ = E%I File Find A Search /4 Browse A Difference 4 Shell A Symbols
to such as an e |File: C:\Program Files\taskingc51v60r \doc\himi\cADEFALILT HTM o= me | [Line1 [Cond

transfer utility or an extended
Clipboard viewer. Make sure
that you select the HTML WYSIWYG Editor/Viewer in the Codel/Vright
Libraries Section at the top, and add the file CWIEXPLR.DLL in the User
Defined Libraries section in the middle. This DLL file can be found in the \ bi n
directory of your tools installation. Once you have made these additional
settings you can open an HTML file and an additional browse window will
open automatically.
Starting a project
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CodeSense - Automatic Word Completion

CodeSense uses tooltips and drop-down lists to complete the names of
symbols (member lists, parameters, function definitions, and other source
code elements). Go-to buttons are also available that allow you to quickly
browse for symbols and symbol definitions. CodeSense information can be
obtained from source code in the current open file, the current project, or
from source code files in custom-specified CodeSense libraries. CodeSense
hover tooltips and drop-down lists will display automatically at appropriate
times while

editing, or recordvar .color = red;

with the recordvar.a = strlen (recordvar.

press of a typedef rec_type:
keystroke. To test this productive feature yourself, @]
you can start inserting one of the recordvar
structure members in the sim sample project
provided with the package. Upon typing the dot, EDE @] ¢
will prompt you with a dropdown list of all members

mublic: short a

public: char B[16]

public: long o

ﬂ color public: color_type color

from which you can select the one you need.

Source and Project Navigation

EDE offers you many ways to navigate through your project and source
code. The project toolbar at the left side of your screen opens by default in
the Project Management view, but through the tabs at the bottom you can
open for example the Bookmark Manager, the Outline Window, the
CodeFolio Manager or the Object Browser. The latter gives you not only
an overview of all objects (variables, functions, defines, etc.) in your source
file, but by selecting an object the focus of the source window instantly
goes to the spot where the object is defined.

As an exercise you may type 'r *" or ™" in the identifier entry field at the top,

while you have the file deno. ¢ of the sim project open. The result should
be equal or similar to the screenshot on the right.

CodeFolio - a.k.a. Code Snippets

To help you using your company's standard b\ AGACELUNCT TRL

templates for source code and source files, ,

EDE offers you the CodeFolio feature. E‘:T‘ CADCLITABINYSnippets

CodeFolio manages your templates and 2.0 asm

frequently used pieces of personal code (also 53¢

known as snippets.) You can create a snippet B File Header

by selecting a part of your code and drag it = Funcion Heade:

into the CodeFolio manager, where you can B Main

drop it in the directory of your choice. Once - Typedef Stuct

you have created a collection of snippets (we =43 cpp

provided a few standard templates with the B Class

package) you can double-click a snippet to B Derived Class

have it inserted at the cursor position in the B File Header

open source file. B Function Header
Eﬁ I ain

CodeFolio snippets may be extended with B 5truct

special CodeFolio macros; CodeFolio =3 html

macros will automatically expand the current w0 pel

date and time, move the cursor to a specific B8 project

location, perform mathematical equations,

and more.

elefelefe]s |

Identifier:l j
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....... &
....... &
....... &

[~ lgnore Case

N
. addone(unsignad int). _regparm unzsighed int j
. factariallunsigned char), unsigned int
. mygetchar(char #). woid
. myputs_rom char ¥, void

s shruck rec_s

- &g color, calor_type

factoriallunsigned char num], unzsigned int
main(void], woid

mygetchar(char *c). void

myputs(_rom char *string), void

& a, short
& b[16], char
@ c long

& blue

bell[2], _rom static char
color_e:blue
color_g:red

color_g:ypellaw

Syrnbal:  yellaw
Definition: erum calar_e | pellow
Filename: C:hdoch1hexamplesiuyw \DERO.C

oufBUfO0 TFOT_CEM]. char
rec_s:a, short

rec_s:b[1E], char

rec_sic, long

rec_scolor, color_type
rec_type, typedef struct rec_s
recordwar, static rec_tipe
statrec, _rom static rec_type
table[7]. _idat unsigned int

IMPUT_LEN 2, Hdefine _|;I
»

£ File |2 0ut.| sa0ti. | @800 ] mop.. | B cod.|
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Selective Display, Collapse/Expand code

From the Text > Selective Display menu you have many options to gain a
better overview of your source code. In the graphic the Multi-level option
is used, which let your functions collapse at the braces level. Clicking on the

B C:\dcchl \examples\xvwADEMO C =

woid
myputs | rom char *string )

éi—f] char *p = outbuf;

while (| #*p++ = watrinct+

; B C:\dcc51\examples\uyw\DEMO C =
_simo| OUTP

il wvoid
myputs ( rom char *string )

i

(+) or (-) in the left column will expand, respectively collapsing your code.
This is just one of the six formatting options to help you keeping the right
focus on your code.

MISRA C Support

Are you concerned about the quality of your code or the reliability of the
application that you develop? Does your product have to comply with safety
related standards? The TASKING 8051 compiler is the only C51 compiler
offering support for the MISRA C guidelines through the MISRA C options
from the Project > Project Options > C Compiler > MISRA C menu. The
Motor Industry Software Reliability Association (MISRA) is a consortium of
companies that developed guidelines on which TASKING's MISRA C code
checking is based. The consortium's effort was in response to the UK Safety
Critical Systems Research Program, and the result is 127 programming rules
applicable when developing safety-related applications in C.

Not every programmer is fully aware of the effects of all the possible
constructs in the C language. For instance, the lack of type checking and the
application of

TASKING 8051 TUTORIAL
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File Manager

Ef

. = =

The EDE does have a file = =

manager integrated to navigate & Frogon Fies B =

. ; g = Elo

through the files of your project. (= 514601 2 =
Maybe that doesn't sound too %Ee:\ir:ples
exiting, as there are already many £ sim 5 5
ways provided yv|th Windows to TR Tow 1_500] Voged 1
browse your disks or network ADDONE  SAC 485 140207 165448 o
driVeS' but thIS manager Offers CSTART  ASM 9536 14-02-01 16:54:50
. demo 3Ic 15171 18-04-00 14:03:02 +
you some extras that particularly sm_cstat asm 1015 180401 140618 44/
are of benefit in a code sim_estart  src 1037 18-04-01 14:09:05 =0
. (=]
development environment: You =5
can for example Touch and Check |
infout files, add your own User n
functions, or define the 1
directories that you often visit. |« | L [ 1

Give it a try! You'll like it. € i |2 0uti. | *20bis. | @ Book | (5 0pen | B Code. |

And more...

A few other interesting features that you may want to try yourself:
Right-click in a window or button bar and browse the list of
applicable options
The match brace facility to outline the scope of e.g. a function
The file difference utility

Integrate your company's source code version control system
into EDE

Setting local and global bookmarks

Extend the functionality of EDE by activating libraries from the
Customize > Libraries menu. A vast collection of additional
libraries is available on the Internet, e.g. at
http://www.starbase.com/support/Code Wright/AddOns
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