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Chapter 1. Product Overview

TASKING® SmartCode consists of several toolsets, which are listed below. This Getting Started manual
and the User Guides describe all features available. In this manual, TASKING SmartCode and SmartCode
are used as synonyms.

C/C++ compiler toolsets
A C/C++ compiler toolset is supported for the following core:

* TriCore™/AURIX™ TC4x.

C compiler toolsets
C compiler toolsets are supported for the following cores:

» Generic Timer Module (GTM) / Multi Channel Sequencer (MCS). In the product and manuals we use
the term "MCS".

» Standby Controller (SCR). This controller is based on Infineon® XC800 microcontroller, which is an
8051 compatible 8-bit microcontroller. In the product and manuals we use the term "8051".

« Infineon Parallel Processing Unit (PPU).

All toolsets are accessible from the Eclipse™ Integrated Development Environment (IDE).
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Chapter 2. Preparing for First Use

This chapter guides you through the installation process of TASKING® SmartCode. It also describes
which documentation is available and how you best can use it.

In this manual, TASKING SmartCode and SmartCode are used as synonyms.

2.1. Installing the Software

This section describes the installation of the embedded software for Windows and Linux. It also describes
how to license the software.

2.1.1. Installation for Windows

System Requirements

Before installation, ensure your system meets the following minimum requirements:
* A 64-Dbit version of Windows 11 or later

» Legacy 64-bit Windows versions starting from Windows 7 are also supported

* 4 GB memory

5 GB free hard disk space

» Screen resolution: 1024 x 768 or higher

Installation
1. If you received a download link, download the software and extract its contents.
-or-
If you received an USB flash drive, insert it into a free USB port on your computer.
2. Run the installation program (setup.exe).
The TASKING Setup dialog box appears.

3. Select a product and click on the Install button. If there is only one product, you can directly click on
the Install button.

4. Follow the instructions that appear on your screen. During the installation you need to enter a license
key, this is described in Section 2.1.3, Licensing.
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2.1.2. Installation for Linux

System Requirements
Before installing, make sure the following minimum system requirements are met:
* 64-bit version of Linux

* Linux distributions must support GLIBC version 2.17 or higher. You can check the version with the
command | dd --version

* 4 GB memory

5 GB free hard disk space

» Screen resolution: 1024 x 768 or higher

Installation

TASKING VX-toolsets on Linux are delivered as GNU zipped tar files (e.g. SW260800-vx.yrz.tar.gz). The
installation is basically just unpacking this file.

1. Goto the directory where you want to install the product. For example, / opt , and issue the following
command:

tar xzvf SW260800-vx.yrz.tar.gz -C /opt

2. License the software as described in Section 2.1.3, Licensing.

2.1.3. Licensing

TASKING products are protected with TASKING license management software (TLM). To use a TASKING
product, you must install that product and install a license.

The following license types can be ordered from TASKING.

Node-locked license

A node-locked license locks the software to one specific computer so you can use the product on that
particular computer only.

For information about installing a node-locked license see Section 2.1.3.3.2, Installing Server Based
Licenses (Floating or Node-Locked) and Section 2.1.3.3.3, Installing Client Based Licenses (Node-Locked).

Floating license

Afloating license is a license located on a license server and can be used by multiple users on the network.
Floating licenses allow you to share licenses among a group of users up to the number of users (seats)
specified in the license.
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For example, suppose 50 developers may use a client but only ten clients are running at any given time.
In this scenario, you only require a ten seats floating license. When all ten licenses are in use, no other

client instance can be used. Also a linger time is in place. This means that a license seat is locked for a

period of time after a user has stopped using a client. The license seat is available again for other users
when the linger time has finished.

For information about installing a floating license see Section 2.1.3.3.2, Installing Server Based Licenses
(Floating or Node-Locked).

Build server license

A build server license is a license on a central computer system, shared (used) by other systems,
automated processes or users. A build server license is limited to a maximum number of parallel processes
per user (seat). A build server license is usually installed as a floating license with a process limit.

When the maximum number of parallel processes is reached a new client process is set to waiting until
the number of running client processes under the same license seat is below the process limit.

License service types

The license service type specifies the process used to validate the license. The following types are
possible:

» Client based (also known as 'standalone’). The license is serviced by the client. All information necessary
to service the license is available on the computer that executes the TASKING product. This license
service type is available for node-locked licenses only.

» Server based (also known as 'network based’). The license is serviced by a separate license server
program that runs either on your companies' network or runs in the cloud. This license service type is
available for both node-locked licenses and floating licenses.

Licenses can be serviced by a cloud based license server called "TASKING Remote License Server".
This is a license server that is operated by TASKING. Alternatively, you can install a license server
program on your local network. Such a server is called a "TASKING Local License Server". You have
to configure such a license server yourself. The installation of a TASKING local license server is not
part of this manual. You can order it as a separate product (SW000089).

The benefit of using the TASKING Remote License Server is that product installation and configuration
is simplified.

Unless you have an IT department that is proficient with the setup and configuration of licensing systems
we recommend to use the facilities offered by the TASKING Remote License Server.

2.1.3.1. Obtaining a License

You need a license key when you install a TASKING product on a computer. If you have not received
such a license key follow the steps below to obtain one. Otherwise, you cannot install the software.

Obtaining a server based license (floating or node-locked)

» Order a TASKING product from TASKING or one of its distributors.
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A license key will be sent to you by email or on paper.

If your node-locked server based license is not yet bound to a specific computer ID, the license server
binds the license to the computer that first uses the license.

Obtaining a client based license (node-locked)

To use a TASKING product on one particular computer with a license file, TASKING needs to know the
computer ID that uniquely identifies your computer. You can do this with the getcid program that is
available on the TASKING website. The detailed steps are explained below.

1. Download the getcid program from https://www.tasking.com/support/tim/downloads.

2. Execute the getcid program on the computer on which you want to use a TASKING product. The
tool has no options. For example,

Windows (GUI):

getcid_version

n Get Computer ID for Mode-lecked Client Based License >

If you have a suitable Internet connection you can install without
"TASK I“G sending a Computer ID to TASKING in advance.
.

Test Internet Connection

Congratulations! Your Internet connection is suitable for activating
your Node-Locked dient based license. All you need is a License Key
from TASKING. Please report this successful connection test to your
TASKING representative.

In case the Internet connection test was not successful, please
copy this Computer ID by dicking the button below and send it to
your TASKING representative by email.

Copy Computer ID to Clipboard |

The computer ID is displayed in the lower part of the dialog.
Windows (command prompt):

getci decnd_versi on

The computer ID is displayed on your screen.

Linux:

./l getcid_version
Conput er| D: 5Dzm L9+Z- WFbO aMkU- 5Dzm L9+Z- WFbO- aMkU- MDAy - Y2Zm

The computer ID is displayed on your screen.
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3. Order a TASKING product from TASKING or one of its distributors and supply the computer ID.
A license key and a license file will be sent to you by email or on paper.

When you have received your TASKING product, you are now ready to install it.

2.1.3.2. Frequently Asked Questions (FAQ)

If you have questions or encounter problems you can check the TASKING Knowledge Base.
https://kb.tasking.com/KB/83

This page contains answers to questions for the TASKING license management system TLM.

If your question is not there, please contact your nearest TASKING Sales & Support Center or Value
Added Reseller.

2.1.3.3.Installing a License

On Windows the license setup procedure is done by the installation program. On Linux you have to install
a license manually.

If the installation program on Windows can access the internet then you only need the license key. Given
the license key the installation program retrieves all required information from the remote license server.
The installation program sends the license key and the computer ID of the computer on which the
installation program is running to the remote license server, no other data is transmitted.

If the installation program cannot access the internet the installation program asks you to enter the required
information by hand. If you install a node-locked client based license you should have the license file at
hand (see Section 2.1.3.1, Obtaining a License).

Floating licenses are always server based and node-locked licenses can be server based. All server
based licenses are installed using the same procedure.

2.1.3.3.1. Configure the Firewall in your Network

For using the TASKING license servers the TASKING license manager tries to connect to the remote
license serverslicl. taski ng.comlic2.tasking.comlic3.tasking.comlic4.tasking.com
at the TCP ports 8080, 8936 or 80. Make sure that the firewall in your network is transparently enabled
for one of these ports.

2.1.3.3.2. Installing Server Based Licenses (Floating or Node-Locked)
If you do not have received your license key, read Section 2.1.3.1, Obtaining a License before you continue.
Windows

1. If you want to use a local license server, first install and run the local license server before you
continue with step 2. You can order a local license server as a separate product (SW000089).

2. Install the TASKING product and follow the instructions that appear on your screen.
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6.

The installation program asks you to enter the license information.

TASKING <product> - InstallShield Wizard >

License Key Information

Spedify your license key TAS I( |QG =

Pleaze enter the license key that you have received from TASKING. The key has the format like
aaa-bbbb-ccoc-dddd. If you do not have a key, please contact TASKING through
licensing @tasking. com, or contact your TASKING representative.

License Key:

Licensing Support < Back Mext = Cancel

In the License Key field enter the license key you have received from TASKING and click Next to
continue.

The installation program tries to retrieve the license information from a remote license server. Wait

until the license information is retrieved. If the license information is retrieved successfully subsequent
dialogs are already filled-in and you only have to confirm the contents of the dialogs by clicking the

Next button. If the license information is not retrieved successfully you have to enter the information
by hand.

Select your License Type and click Next to continue. If the license type is already filled in and grayed
out, you can just click Next to continue.

You can find the license type in the email or paper that contains the license key.

(For floating licenses only) Select Remote license server to use one of the remote license servers,
or select Local license server for a local license server. The latter requires optional software.

(For local license server only) specify the Server name and Server port of the local license server.

Click Next and follow the rest of the instructions to complete the installation.

Linux

1.

If you want to use a local license server, first install and run the local license server before you
continue with step 2. You can order a local license server as a separate product (SW000089).

After installation of the TASKING product, the license options file | i copt . t xt is present in the
directory <install-dir>/ <product-name>/ et c, for example / opt / Smar t Code/ et c for the SmartCode
product, assuming you have installed the TASKING product in / opt . Edit this file with a text editor
and change the line:
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TSK_LI CENSE_KEY_SW260800 = 0000- 0000- 0000- 0000
Replace 0000- 0000- 0000- 0000 with the license key you obtained from TASKING.

3. Set the environment variable TSK_OPTI ONS_FI LE_<Pr oduct - Code><ver si on> to the absolute
location of | i copt . t xt . For example:

TSK_OPTI ONS_FI LE_SW260800v10_4r 1=/ opt / Snart Code/ etc/ | i copt . t xt
export TSK_OPTI ONS_FI LE_SW260800v10_4r1
2.1.3.3.3. Installing Client Based Licenses (Node-Locked)

If you do not have received your license key and license file, read Section 2.1.3.1, Obtaining a License
before continuing.

Windows
1. Install the TASKING product and follow the instructions that appear on your screen.

The installation program asks you to enter the license information.

TASKEING <product> - InstallShield Wizard e

License Key Information

Spedify your license key TAS I( IQG -

Flease enter the license key that you have received from TASKING. The key has the format like
aaa-bbbb-cccc-dddd. If you do not have a key, please contact TASKING through
licensing @tasking.com, or contact your TASKING representative.

License Key:

Licensing Support < Back Mext = Cancel

2. Inthe License Key field enter the license key you have received from TASKING and click Next to
continue.

The installation program tries to retrieve the license information from a remote license server. Wait

until the license information is retrieved. If the license information is retrieved successfully subsequent
dialogs are already filled-in and you only have to confirm the contents of the dialogs by clicking the
Next button. If the license information is not retrieved successfully you have to enter the information
by hand.
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TASKING «<product> - InstallShield Wizard *
License Type Information
Choase your license type TAS I( l“G .

License Type

ModeHocked server based license
(®) NodeJocked dient based license

() Floating license

Licensing Support < Back Cancel
3. Select Node-locked client based license and click Next to continue.
TASKING <product> - InstallShield Wizard >
Mode-locked Client Based
Spedfy your license file content TASI( l“G,

License File Contents:

Licensing Support < Back Mext = Cancel

4. Inthe License File Contents field enter the contents of the license file you have received from
TASKING.

The license data is stored in the file licfile.txt in the etc directory of the product (<install_dir>\etc).

5. Click Next and follow the rest of the instructions to complete the installation.
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Linux

1.

Install the TASKING product and put the licensefilel i cfi | e. t xt you have received from TASKING
in the directory <install-dir>/ <product-name>/ et c. For example, if you installed a SmartCode product
in/ opt, the path is / opt / Snart Code/ et c

After installation of the TASKING product, the license options file | i copt . t xt is present in the
directory <install-dir>/ <product-name>/ et c. Edit this file with a text editor:

a. Change the line:
TSK_LI CENSE_KEY_SW260800 = 0000- 0000- 0000- 0000
Replace 0000- 0000- 0000- 0000 with the license key you obtained from TASKING.
b. Change the line:
#TSK_LI CENSE_FI LE_SW260800 = licfile.txt
to:
TSK_LI CENSE_FI LE_SW260800=/ opt / Smart Code/ etc/licfile.txt
Specify the absolute path to the filel i cfil e. t xt.
Set the environment variable TSK_OPTI ONS_FI LE_<Pr oduct - Code><ver si on> to the absolute
location of | i copt . t xt . For example:

TSK_OPTI ONS_FI LE_SW260800v10_4r 1=/ opt/ Smart Code/ etc/ | i copt .t xt
export TSK_OPTI ONS_FI LE_SW260800v10_4r1

2.2. Starting / Closing the SmartCode Eclipse IDE

The TASKING SmartCode uses Eclipse as the Integrated Development environment (IDE).

Starting the SmartCode Eclipse IDE

To start the SmartCode Eclipse IDE:

1.

On Windows PCs, from the Start menu, select TASKING SmartCode vx.yrz » SmartCode Eclipse
IDE.

On UNIX/Linux workstations, type eclipse at a shell command prompt, assuming that the TASKING
SmartCode eclipse directory is in the search path.

The Workspace Launcher dialog appears.
Enter the path to the workspace.

In the remainder of this manual, we assume you use the default.

11
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3. Enable the option Use this as the default and do not ask again.
4. Click OK to proceed.

Initially, the SmartCode Eclipse IDE opens with a workbench displaying the C/C++ perspective with
several views and the Welcome view visible. The Welcome view provides some general information and
alternative ways to access the online documentation.

» Close the Welcome view when you want to create more space on your screen.

{Ja) Welcome &2

Your workbench should now look similar to this:

@ workspace_smartcode_vx.yrz - SmartCode Eclipse IDE vx.yrz - [m] x
File Edit Source Refactor Mavigate Search Project Debug Window Help
g BiRig-aiedr@- SRR IEE R - Bl = N - O A =
0 C/C++ Projects X =g = B |[5 outline X =g
=Y
There is no active editor that
provides an outline.
[& Problems 3 . E] Console| [ Properties 7 § = 08
0 items
Description Resource Path Location [ Type
< >

At any time you can get the Welcome view back again by selecting Welcome from the Help menu.

12
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Closing the SmartCode Eclipse IDE
To close SmartCode Eclipse IDE:
* From the File menu, select Exit.

Upon exit, the SmartCode Eclipse IDE saves the current workbench layout. The next time you start the
SmartCode Eclipse IDE, the last saved workbench layout is used.

2.3. Install Solutions from the Eclipse Marketplace

The Eclipse IDE includes the Eclipse Marketplace Client. This provides a means to find and install solutions
from the Eclipse Marketplace and other solution catalogs, such as GitHub Copilot.

To launch the Eclipse Marketplace Client select Help » Eclipse Marketplace... from the menu.
For more information, read the Eclipse Marketplace User Guide under Help » Help Contents.
Customer Responsibility

Solutions you install via the Eclipse Marketplace are your own responsibility.

You are responsible for:

» Compliance with Eclipse's licensing terms and any additional Eclipse plugins you install

» Understanding Eclipse's data handling practices and workspace storage

» Any third-party Eclipse plugins or extensions you choose to install

» Eclipse IDE updates, security patches, and compatibility issues

By enabling and using any Al coding plugin, you acknowledge that:

* You are solely responsible for any source code, data, or information shared with the Al service
» You must ensure compliance with your organization's data privacy and security policies

 You are responsible for reviewing and validating all Al-generated code suggestions before implementation
« Any intellectual property or licensing implications of Al-generated code are your responsibility
Recommendation for using Al coding plugins:

Review the Al plugin provider's terms of service, privacy policy, and data usage practices before activation.
Consider your organization's data classification and sharing policies before using Al coding assistance
with proprietary or sensitive code.

13
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2.4. How to Use the Documentation

The documentation for TASKING SmartCode consists of:
» documentation for Eclipse

« this Getting Started manual

» TASKING SmartCode - TriCore User Guide

» TASKING SmartCode - MCS User Guide

» TASKING SmartCode - 8051 User Guide

» TASKING SmartCode - ARC/PPU User Guide

» TASKING winIDEA Help

It is strongly recommended to read the documentation in this order:

Getting acquainted with Eclipse

If you are new to Eclipse, start familiarizing with Eclipse. Eclipse comes with several online documents.
One document describes how Eclipse is organized as a Workbench, with Perspectives that contain Views;
another document explains how to create a sample C/C++ project, build and debug it (CDT documentation).

To start with this documentation:
1. Start Eclipse.
2. From the Help menu, select Help Contents.
The help screen overlays the Eclipse Workbench.
3. Inthe left pane, select Workbench User Guide to learn more about working in Eclipse.

4. Continue with C/C++ Development User Guide to learn more about creating and developing a
C/C++ project.

This part of the documentation explains how to create a "hello world" example. Be aware that this
example does not use the TASKING tools, it uses the standard GNU compiler in Eclipse instead.

Getting started with SmartCode (this manual)

The TASKING Getting Started and TriCore User Guide contain specific information for the TASKING
toolset for TriCore. Its content overrides any information found in the Eclipse and CDT documentation.

The next chapters of this manual explain how to setup and work with a TriCore project. It shows some
important features of the TriCore toolset.

14
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TASKING User Guides

Once you are introduced to Eclipse and the TriCore toolset, you can start creating your own projects. The
documentation for the TriCore toolset covers the TriCore C/C++/Assembly language, as well as detailed
description of the various tools and options. Accessing the documentation for the TriCore toolset is similar
to accessing the documentation for Eclipse:

1. Start Eclipse.
2. From the Help menu, select Help Contents.
The help screen overlays the Eclipse Workbench.

3. Inthe left pane, select TASKING SmartCode - TriCore User Guide to access the documentation
for the TriCore toolset or select one of the other toolset User Guides.

The TASKING manuals are also available in PDF format via the Windows Start menu:

* In the Start menu, browse to TASKING SmartCode vx.y.rz and select the manual you need.

TASKING winIDEA Help

For information how to use the winIDEA debugger, see the online winIDEA Help.

2.5. Related Publications

C Standard

» C A Reference Manual (fifth edition) by Samual P. Harbison and Guy L. Steele Jr. [2002, Prentice Hall]

ISO/IEC 9899:1999(E), Programming languages - C [ISO/IEC]

* ISO/IEC 9899:2011(E), Information technology - Programming languages - C [ISO/IEC]

ISO/IEC 9899:2018(E), Information technology - Programming languages - C [ISO/IEC]

More information on the standards can be found at http://www.iso.org/

DSP-C, An Extension to ISO/IEC 9899:1999(E), Programming languages - C [TASKING, TK0071-14]

C++ Standard
* ISO/IEC 14882:2011 C++ standard [ISO/IEC]
* ISO/IEC 14882:2014 C++ standard [ISO/IEC]
» ISO/IEC 14882:2017 C++ standard [ISO/IEC]
More information on the standards can be found at http://www.iso.org/

» The C++ Programming Language (second edition) by Bjarne Straustrup [1991, Addison Wesley]

15
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» The Annotated C++ Reference Manual by Margaret A. Ellis and Bjarne Straustrup [1990, Addison
Wesley]

CERT C Secure Coding Standard
» The CERT C Secure Coding Standard by Robert C. Seacord [October 2008, Addison Wesley]
» The CERT C Secure Coding Standard web site http://www.securecoding.cert.org/

For general information about CERT secure coding, see http://www.cert.org/secure-coding

MISRA C

* MISRA C:2012, Guidelines for the use of the C language in critical systems [MIRA Ltd, 2013]
See also https://misra.org.uk/

* MISRA-C:2004, Guidelines for the Use of the C Language in Critical Systems [MIRA Ltd, 2004]
See also https://misra.org.uk/

» Guidelines for the Use of the C Language in Vehicle Based Software [MIRA Ltd, 1998]

See also https://misra.org.uk/

TriCore
» TriCore 1.8 Core Architecture User's Manual [Infineon]

» TC1.8 Functional Description [Infineon]

8051

» TASKING 8051 EABI, Document ID: C51-75 [2022, TASKING BV]

ARC/PPU

» DesignWare ARCv2 ISA Programmer’s Reference Manual for DW EV7x Processors, Version 6413-001
[February 2021, Synopsys, Inc.]

» DesignWare EV7x Processor Databook, Version 6368-004 [April 2020, Synopsys, Inc.]

» DesignWare ARCv2 System V ABI Supplement User's Guide, Version 4092-007 [Nov 01, 2019,
Synopsys, Inc.]
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Chapter 3. Setting up a Project

This tutorial shows how to create an embedded software project with the TriCore toolset. It lets you create
your own project with a simple "Hello World" example. The steps to create and build projects for the other
toolsets that are part of the TASKING SmartCode product, MCS, 8051 and ARC/PPU, are similar to that
of the TriCore toolset.

By now you should be familiar with the Eclipse workbench, perspectives and views. If you are not, please
read the Eclipse documentation as described in Section 2.4, How to Use the Documentation.

3.1. Create a Project

Set the TASKING C/C++ perspective

Before creating a TriCore project, it is necessary to have the TASKING C/C++ perspective on the
workbench. By default, this should be the case when you start Eclipse, but if it is not, do the following:

1. Start Eclipse.
Eclipse starts with the last saved workbench layout.

2. To open the TASKING C/C++ perspective: from the Window menu, select Open Perspective »
Other... » TASKING C/C++.

The name of the perspective is displayed in the title bar of the workbench window.
If you attempt to create a TriCore project while the TASKING C/C++ perspective is not active, Eclipse
will ask you to activate the TASKING C/C++ perspective after you finish the New C/C++ Project wizard.
Create aTriCore project with the New C/C++ Project wizard
1. From the File menu, select New » TASKING TriCore C/C++ Project
The New C/C++ Project wizard appears.
2. Enter a name for your project, for example nypr oj ect .
In the Location field you will see the location where the new project will be stored. To change the
default location, you can uncheck the Use default location check box and browse for an alternative
location. However, use the default location for now.

3. Inthe Project type box you can select whether to create an application, a position independent
module or a library.

» Expand TASKING TriCore Application and select Hello World C Project. This creates the file
nmypr oj ect . ¢ with a simple main function.

» Click Next to continue.
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The TriCore Project Settings page appears.

Mew C/C++ Project O X

TriCore Project Settings —,

€3 Select 3 processorto continue

Processor selection
[ Infineon AURLX™ TC4x Family

Expand All

Expand Selected

Collapse All
Multi-core configuration
Actions
] Add startup file(s) to the project
Add linker script file to the project
'/?:' < Back Mext = Finish Cancel

4. Select the target processor for which you want to build the application. For example TC49x. Afterwards
you can always change the processor in the Project » Properties for dialog.

5.  When you selected a multi-core processor, select the multi-core configuration you want to use. If you
want to create a multi-core project, select All cores. If you want to create a project for a single core
on a multi-core processor, select the specific core.

6. You can choose to add C startup code to your project and/or add a linker script file to your project.

» Enable Add startup file(s) to the project. This adds the files cstart. c and cst art . h to your
project (or the _t ccor e variants), which are necessary for building C programs. These files are
copiesofl i b/src/cstart*. c andi ncl ude/ cstart*. h.If you do not add the startup file(s)
here, you can always add them later with File » New » Startup Files.

» Enable Add linker script file to the project. This adds the file mypr oj ect . | sl to your project
which can be edited to customize linking and locating. If you do not add the linker script file here,
you can always add it later with File » New » Linker Script File (LSL).

For details on changing the C startup code and linker script file refer to the TASKING SmartCode -
TriCore User Guide.

7. Click Next. This button is only enabled for 'All cores' and 'Core 0' projects.

The Target Settings page appears.
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MNew C/C++ Project O >

Target Settings ——

Create a configuration to launch the debugger

Name: | myproject

Target| i= Initialization | 2] Project | 0= Arguments| . Source| [] Miscellaneous
Target settings
(O Show all targets (8 Show targets for TC4%x

Target: TriCere 1.8 Instruction Set Simulator

Configuration:

[] Add launch configuration to the project

'/'7:' < Back Mext = Cancel

Note that you can only specify a target launch configuration for an 'All cores' or ‘Core 0' project.
If you create a single-core project for one of the other cores, you also need a ‘Core 0' project to
start the other core project. See Section 3.9, Refer to Another Project from a TriCore Project.

8. In order to debug your project you need to create a debug configuration.
» Select a target. For this example we select the TriCore 1.8 Instruction Set Simulator.
» Enable Add launch configuration to the project. This allows you to debug your project.

» Leave the other tabs as is. For more information, see section Creating a Customized Debug
Configuration in Chapter Using the Debugger of the TASKING SmartCode - TriCore User Guide.

9. Click Finish to finish the wizard and to create the project.

The project has now been created and is the active project. If you click on the Build myproject
button (), the project is built and should give no errors or warnings.

The left-hand pane of the Workbench window has two views. The C/C++ Projects view shows the structure
of your projects, complete with all files that are used in the project.

In the standard Eclipse documentation about the workbench is described how you can move and
organize views on your workbench.
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3.2. Delete a Project

The project as you just created, is stored as a subfolder named nypr oj ect in the folder
C:. \ User s\ name\ wor kspace_smart code_version. To delete a project, it needs to be properly removed
from the workbench. To delete the project which you just created:

1. Inthe C/C++ Projects view, right-click on the name of the project, mypr oj ect, and select Delete.
A dialog appears which asks for confirmation.

2. Enable Delete project contents on disk (cannot be undone). This will remove your project from
the workbench and also removes the entire mypr oj ect subfolder from your hard disk.

If you disable this option, this would have removed your project from the workbench, but leaves it on
you hard disk. Files can be used later in other projects, or you can later import the whole project.

3. Click OK to confirm.

3.3. Manually Add a File to Your Project

We will recreate the project as described in Section 3.1, Create a Project; however, this time without the
automatic 'Hello World' example C source file. Instead, the example below illustrates how you can manually
add a file to your project.

Recreate your project without 'Hello World'

1. Firstrepeat steps 1 and 2 of Create a TriCore project with the New C/C++ Project wizard in
Section 3.1, Create a Project.

2. Inthe Project type box you can select whether to create an application or a library.

» Expand TASKING TriCore Application and select Empty Project. This creates a project without
a C source file containing the function mai n() .

» Click Next to continue.
The TriCore Project Settings page appears.

3. Repeat steps 4 through 9 of Create a TriCore project with the New C/C++ Project wizard in
Section 3.1, Create a Project.

4. Click Finish to finish the wizard and to create the project.
Add a new file to your project

To add a new, empty file:

1. Inthe C/C++ Projects view, right-click on the name of the project, mypr oj ect, and select New »
Source File.
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The New Source File dialog appears.

2. Specify a source folder and a name for the new file. By default, the new file will be stored in the
project folder (in this case: mypr oj ect ). If your projects contains multiple folders, you can browse
for an alternative source folder to store the new file in.

* Inthe Source folder field, make sure it refers to mypr oj ect .

* Inthe Source file field, type the name of the new file, for example myf i | e. c. Note that for C files
you must specify the extension . c! For C++ files use the extension . C, . cc, . cpp Or . CXX.

* Inthe Template field, select a code template for your source file, for example Def aul t C source
t enpl at e or select <None> if you want to start with an empty file. Note that you can configure
your own templates if you click on the Configure... button.

3. Click Finish to continue.

The new file nyfi | e. c is created and ready for editing in the editor view.

Add an existing file to your project (import)
There are three ways to add a file to your project:

» Import a file (the original file is copied to the project folder)
» Create afile in the project folder

» Create a link in the project folder to an existing file

Import a file

Instead of creating a new file, it is also possible to import an existing file into your project or to create a
file directly in the mypr oj ect folder. To demonstrate this, follow the steps below. Do not close Eclipse.

« First create a C source file (for example exi st i ng. c¢) with a standard editor outside Eclipse. (As
content you can, for example, use a single line containing comments only).

* You can store the file anywhere on your hard disk, but not in your project folder (for example in C: \ TEMP

).
In Eclipse, follow the next steps to import the existing file:
1. Inthe C/C++ Projects view, right-click on the project mypr oj ect and select Import...
The Import wizard appeatrs.
2. Select General » File System. Click Next to continue.

3. Inthe From directory field, type the path to the directory where you saved exi st i ng. ¢ (for example
C:\ TEMP) and click in the empty white box below.
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The left box shows the file structure of the directory, the right box shows the files located in that
directory, similar to the Windows Explorer.

4. In the left box, select the folder TEMP.

5. In the right box, select the file exi sti ng. c.

6. Click Finish to finish the wizard and import the file into your project.

The file exi st i ng. c is copied from its location at C: \ TEMP into your project folder and is added to your
project. It is now visible as a C source file in the C/C++ Projects view. Changes you make to this file, will
not affect the original file stored in C. \ TEMP. Also, removing this file from your project will remove the file
also from your project folder, but the original file remains untouched.

Create afile in the project folder

Instead of importing a file, you can create the file exi st i ng. ¢ with a standard editor outside Eclipse,
and store it directly in the mypr oj ect folder. To add the file to your project:

 In the C/C++ Projects view, right-click on mypr oj ect and select Refresh.
The file exi st i ng. ¢ should now be visible as part of your project.
Create a link in the project folder to an existing file

The third way to add a file to your project, is to create a link to an existing file which is stored on a different
location:

1. Inthe C/C++ Projects view, right-click on the project mypr oj ect and select New » File from
Template.

The New File wizard appears.

2. Select the project folder in which to create the link: type the name of your project (mypr oj ect ) or
select the project in the box below.

3. Inthe File name field, enter a name for the link, for example | i nk2exi sti ng. c.
4. Click the Advanced >> button.
Additional options appear on the dialog to let you create a link to an existing file.
5. Enable the option Link to file in the file system.
6. Browse to the location where exi st i ng. c is located, select this file and click the Open button.

7. Click Finish to finish the wizard and create the link to the file in your project.

Remove a file or link from your project
As we do not need this file for the remainder of this tutorial, we can safely remove it again from the project:

 In the C/C++ Projects view, right-click on the file | i nk2exi sti ng. ¢ and select Delete.
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The link | i nk2exi st i ng. ¢ is no longer part of your project and has been removed from your project
folder. The original file, however, remains untouched at its original location.

 In the C/C++ Projects view, right-click on the file exi sti ng. ¢ and select Delete.

The file exi sti ng. c is no longer part of your project and has been removed from your project folder.

Be aware that when you remove a file from your project, it always will be removed from its location in
the project folder on your hard disk too!

3.4. Editing Files: C/C++ Editor

Editing a file

Enter the following simple C source in your new source document (the code deliberately contains a
mistake, which you will correct later on):

#i ncl ude <stdi o. h>

int main( void)

{
}

Note the following:

printf( "Hello World\n" ) /* <- mssing semcolon */

» The tab label of the editor view shows an asterisk in front of the file name (* nyfi | e. ¢) to indicate that
the file has been modified.

e The C/C++ editor view uses syntax coloring.

» The Outline view shows the structure of the file. You can use this view to navigate through (larger)
source files easily. Alternatively you can expand the structure of the file in the C/C++ Projects view.

» Right-clicking in the editor view presents you with a list of menu commands.

» To receive more help about the editor view, make sure it is active and press F1.

Saving and closing a file

To save the file:

* From the File menu, select Save (Ctrl+S).
The project will be saved.

To close the file:

» From the File menu, select Close Editor (Ctrl+W).
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Eclipse will ask you to save the files that have been modified since the last save.

Notice also the menu commands Save All and Close All Editors which you can use when you are
working with multiple files.
Opening a file in the C/C++ editor

There are several ways to open an existing file. An easy way to open the C source file myfi | e. ¢ directly
in the C/C++ editor is:

* In the C/C++ Projects view, double-click on the file name.
Eclipse recognizes the file as a C source file and opens the file in the C/C++ editor.

» Correct the file by entering the missing semicolon. Save and close the file.

Opening afile in a system editor

If you want to open a C source file in an application (editor) outside Eclipse (instead of the built-in C/C++
editor), proceed as follows:

* In the C/C++ Projects view, right-click on the file myf i | e. ¢ and select Open With » System Editor.

The file opens in the application that is associated with the file extension . c.

3.5. Closing, Opening and Activating a Project

Closing a project
Like files, you can close a complete project. To do so:
1. Inthe C/C++ Projects view, right-click on the project nmypr oj ect and select Close Project.

If there are unsaved files, the Save Resources dialog appears in which you can choose which modified
files need to be saved before closing the project.

2. Select the files you want to be saved and click OK to continue.

Any selected unsaved files are saved first, then the project closes. In the C/C++ Projects view the
project mypr oj ect is now visible as a closed map.

Opening a project
To reopen the project again:

* In the C/C++ Projects view, right-click on the project mypr oj ect and select Open Project.

The project is open for modifications again. You may need to expand the project structure to view its
contents.
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Activating a project

The project related menu items and buttons act on the currently active project. When you create a new
project, the new project automatically becomes the active project. If you want to work with another project,
you have to make it active first.

To make a project active:
* In the C/C++ Projects view, right-click on the project nypr oj ect and select Set Active Project.

The project is now active. This is mentioned after the project name. Project properties, build and debug
will act on this active project.

3.6. Copy a Project

If you want to use a project as a starting point for a new project, you can make a copy of a project. Not
only a copy of a project is made, but also the project specific filenames and settings will reflect the new
project name.

To copy a project:

1. Inthe C/C++ Projects view, right-click on the project mypr oj ect and select Copy.

2. Inthe C/C++ Projects view, right-click on the project mypr oj ect and select Paste.
The Copy Project dialog appears.

3. Enter a name for your new project, for example Copy of nyproj ect.

In the Location field you will see the location where the copy of your project will be stored. To change
the default location, you can uncheck the Use default location check box and browse for an
alternative location. However, use the default location for now.

4. Click Copy to continue.

Eclipse makes a copy of the project, renames the LSL file and updates the project configuration and
launch configurations. In the C/C++ Projects view the project Copy of nyproj ect is now visible
as a closed map and is the active project.

3.7. Setting Project Options

Now you are familiar with opening and editing (files in) your project, we will have a look at the options
you can set for building your project.

First make sure the project nypr oj ect is open.

To access the options for your project:

1. From the Project menu, select Properties for. Alternatively, you can click the /= button.
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The Properties for myproject dialog appears.
2. If not selected, expand C/C++ Build and select Settings to access the TriCore tool settings.

A screen similar to the following should now appear.

5% Properties for myproject o «%
Rescurce
Builders
v C/C++ Build Configuration: |Debug [ Active ] ~ | | Manage Configurations...
Build Variables
Environment
Logging "8} Tool Settings | # Build Steps| ' Build Artifact | [} Binary Parsers| € Error Parsers
Memory
Processor @ Global Options Use global "preduct directory’ preference
Settings w 83 C/C++ Compiler S{eclipse_homel}/../ctc Browse...
Stack/Heap (2 Preprocessing
Startup Configuration @ Include Paths [ Treat warnings as errors
Startup Registers (22 Precompiled C++ Headers Keep temporary files
C/C++ General (£ Language [ Verbose mode of control program
Project Natures (2 Floating-Point
Project References (£ Code Generation
Run/Debug Settings (2 Allocation

~ (2 Optimization
(# Custom Optimization
(& Compilation Speed
(2 Debugging
v (3 MISRA C
(2 Custom 2012
(2 Custom 2004
(2 Custom 1993
v @ CERT C Secure Coding
(8 Custom CERT C
(% Diagnostics
(% Miscellaneous
w 3 Assembler
(2 Preprocessing
(2 Include Paths
(2 symbols
(£ Optimization
(B List File
(% Diagnostics
(22 Miscellaneous
w 183 Linker
{3 Patching
(% Output Format
(E Libraries
(£ Data Objects
(2 Script File
(£ Optimization
(2 Map File
(22 Diagnostics
(2 Miscellaneous

Restore Defaults Apply
@ Apply and Close Cancel

On the Tool Settings tab, the options are grouped in Global Options, C/C++ Compiler, Assembler and
Linker or Archiver if you are building a library. Note that the options you enter in the Assembler page are
not only used for hand-coded assembly files, but also for the assembly files generated by the compiler.
In the Configuration field, you can choose a configuration for which you want to make changes. Note
that this does not make the configuration active.

For a detailed description of all TriCore toolset options refer to the TASKING SmartCode - TriCore User
Guide.
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Selecting a predefined build configuration

A build configuration is a predefined set of options. When you created the example project nypr oj ect
as described in Section 3.1, Create a Project, you should be able to choose between the Debug and the
Release configuration. Both have their own settings. Check this for your self:

1. Select the Release configuration.
2. Expand the C/C++ Compiler entry and select Debugging.

The option Generate symbolic debug information is set to None.
3. Select the Debug configuration.

The option Generate symbolic debug information is set to Default.

Setting options and restoring defaults

You can use one of the available configurations as starting point for setting your options. For now, choose
the Debug configuration.

1. Change the option Default to Full.

At this point you can change as many options as you like.
2. Click Apply to apply the new setting(s) to your project.

The dialog does not close, but the new options are saved to the Debug configuration.
To restore to the default Debug configuration options:
1. Click the Restore Defaults button.

The option settings are changed to the default settings of the chosen configuration.
2. Click Apply to apply the default settings to your project.

If you change options without applying them and you try to change the configuration, you are asked
whether to apply the changes first.

Creating your own build configuration
Because of the amount of possible options, it may be very convenient to create your own build configuration.
1. Click on the Manage Configurations... button next to the Configuration field.

The Manage Configurations dialog appears.

2. Click on the New... button.

The Create New Configuration dialog appears.
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3. Type a Name (Myconfi g) and optional a Description for your configuration.
In the Copy settings from box, you can choose the initial option settings for your configuration:
4. Select Existing configuration and choose the Debug configuration.

The existing Debug configuration is the same as the default Debug configuration because we applied
the default settings in the previous example.

5. Click OK.

The Manage Configurations dialog shows the new configuration.
6. Select the new configuration (Myconfi g) and click Set Active.
7. Click OK.

Your new configuration has become the active configuration. From now on, a build will use the option
settings from the Myconf i g configuration. Note that when you select a configuration from the
Configuration field, this only affects the property pages; it does not make the configuration active.

Important: the Restore Defaults button is still associated with the default Debug configuration! Because
the new configuration Myconf i g is based on the Debug configuration, the defaults of the Debug
configuration also apply to the Myconf i g configuration.

Creating your own defaults

The previous example showed how to create your own build configuration to store settings. However, it
was impossible to return to your own defaults, only the original Debug and/or original Release defaults
were available. Below it is described how you can create your own defaults. Basically, you create a
configuration A in which you set your own defaults; then you create a new configuration B which will be
based on configuration A:

If you have found a satisfying combination of option settings, you can create a configuration named
Mydefaul ts.

1. First change the option settings to your own needs.

2. Repeat steps 1 through 7 of Creating your own build configuration but in step 3, type the name
Mydef aul ts.

Normally, any settings you change from here, are saved to Mydef aul t s, thus loosing your original
defaults. To prevent this:

1. Repeat steps 1 through 3 of Creating your own build configuration, to create a second new
configuration and name it Mywor kopt i ons. The name suggests that this will be the configuration
for experimentally changing option settings.

2. Select Existing configuration and choose the Mydefaults configuration.

Your new 'working' configuration is now the same as the configuration named Mydefaults.
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3. Click OK.

The Manage Configurations dialog shows the new configuration.
4. Select the new configuration (Mywor kopt i ons) and click Set Active.
5. Click OK.

Now you can work with the Mywor kopt i ons configuration. If you want to return to your defaults, you
can either make the Mydef aul t s configuration active, or create a new configuration using the
Mydef aul t s configuration to copy the settings from.

3.8. Build a Project

When you build a TASKING TriCore C/C++ project in Eclipse, the TASKING TriCore C/C++ compiler,
assembler and linker are used to compile and link all the source code and the libraries associated with
the project.

To build a project:
» From the Project menu, select Build myproject.

From the Project menu, the following "Build" commands are available:

Build Project Builds the selected project.

Build Working Set »  Opens a wizard in which you can create a customized set of files that will be
built.

Clean... Removes all intermediate files that are created during a build. As a consequence,
the next build cannot rely on existing results from previous builds (thus simulating
a rebuild).

Build Automatically  If you set this option, the selected project will be built automatically after each
applied change in the project properties and after each saved change in the
source files. This way of building is not recommended for C/C++ development.
In order for this option to work, you must also enable option Build on resource
save (Auto build) on the Behavior tab of the C/C++ Build page of the Project
» Properties for dialog.

Build project Builds the active project.

Rebuild project Rebuilds the active project. This builds every file in the project whether or not
a file has been modified since the last build. A rebuild is a clean followed by a
build.

3.9. Refer to Another Project from aTriCore Project

To tell a TriCore project that another project (a TriCore single-core project, MCS project, 8051 project,
ARC project or MIL library project) should be part of it, you need to create a project reference:

1. Inthe C/C++ Projects view, right-click on the name of a TriCore project and select Properties.
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The Properties dialog appears.
2. Inthe left pane, select Project References.

3. Inthe right pane, select the project that must be part of the TriCore project and click Apply and
Close.

Note that when you change the active build configuration of the main TriCore project this does not
automatically change the active build configuration of the linked sub-project. To select the active build
configuration for both projects, for example when switching from Debug to Release, select both the main
project and the sub-project in the C/C++ Projects view by holding down the Ctrl key and clicking on both
projects. Then, right-click and select the active configuration for both projects from Build Configuration
» Set Active.

3.10. Using the Sample Projects

TASKING SmartCode comes with a number of examples (delivered in the directory <i nst al | ati on
pat h>\ <t ool set >\ exanpl es) for each toolset. Each directory contains a file r eadne. t xt with
information about the example.

You can import the TriCore examples via the Welcome page. This is an alternative for importing existing
projects via the File » Import » TASKING C/C++ » TASKING TriCore Example Projects wizard.

Similarly, you can choose TASKING 8051 Example Projects, TASKING ARC Example Projects or
TASKING MCS Example Projects from the Import wizard.

Import an existing project from the Welcome page
1. From the Help menu, select Welcome.
The Welcome page appeatrs.

2. Click the following button:

The Samples page appears.
3. Click TriCore examples.
The Import dialog appears.
4. Select the TriCore examples you want to import into the current workspace.

5. Click Finish
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The original examples are copied into the current workspace.

The project(s) should now be visible in the C/C++ Projects view.

You can set additional project options and build the sample projects as explained in the previous sections.

3.11. Import/Export Project Properties

You can export project properties into a file (. pr op), so that you can import a specific configuration into
a project whenever you want (for example in another workspace).

Export project properties

1.

From the File menu, select Export.

The Export dialog appears.

Select TASKING C/C++ » TASKING C/C++ Project Properties and click Next.

The Export TASKING C/C++ Project Properties dialog appears.

Select the project and configuration from which you want to export the project properties.
Specify the destination properties file (extension . pr op) and click Finish.

The properties will be saved in the specified file.

Import project properties

1.

From the File menu, select Import.

The Import dialog appears.

Select TASKING C/C++ » TASKING C/C++ Project Properties and click Next.
The Import TASKING C/C++ Project Properties dialog appears.

Specify the properties file (extension . pr op) you want to import.

Select the destination project and configuration into which you want to import the project properties
and click Finish.

The properties of the selected project will be replaced by the properties from the selected file.
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Chapter 4. Debugging your Application

Before you start with this chapter, it is recommended to read the Eclipse documentation first. It provides
general information about the debugging process. This chapter guides you through a number of examples
using the TASKING debugger with simulation as target.

You can find the Eclipse documentation as follows:

1.

2.

Start Eclipse.

From the Help menu, select Help Contents.

The help screen appears.

In the left pane, select C/C++ Development User Guide.

Open the Getting Started entry and select Debugging projects.

This Eclipse tutorial provides an overview of the debugging process. Be aware that the Eclipse
example does not use the TASKING tools and TASKING debugger.

4.1. Setting up a Project for Debugging

4.1.1. Create a Sample Project

1.

Create or reopen the project mypr oj ect as created in Section 3.1, Create a Project. Use the default
values and make sure that you:

 select Hello World C project in the New C/C++ Project wizard.

» enable at least the Debug configuration.

Edit the file mypr oj ect . ¢ as follows:

#i ncl ude <stdi o. h>

int main( void)

{

int i;

for (i=1; i<=3; i++)

{

printf( "%\n",i );

}

printf( "Hello world, " );

printf( "this is \n" );

printf( "a small %adst\n",i-3 );

printf( "debuggi ng exanple.\n" );
}
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3.

4.

Save the file.

Build your project.

To be able to debug, it is essential that your project has been built properly!

All steps required above are demonstrated in Chapter 3, Setting up a Project.

Debugging an 8051 project

In order to debug an 8051 project, follow the steps below.

1.

2.

8.

Create an 8051 project (for example, nypr oj ect ), as explained above.

(Optional) Build the 8051 project. This step is optional because the . out file is built automatically
when the project is referenced and built from a TriCore project. See step 5.

This results in a linked output file (. out ).

Create a TriCore project.

In the TriCore project, make a project reference to the 8051 project.
Build the TriCore project.

This builds the referenced 8051 project and creates the . out file in the Debug directory of the 8051
project. Furthermore this creates a TriCore ELF file and an 8051 ELF file in the Debug directory of
the TriCore project.

Make the 8051 project the active project.

Create a debug configuration for the 8051 project, as explained in Section 4.1.2, Create a Debug
Configuration.

Start the debugger, as explained in Section 4.2, Start a Debug Session.

If you want to debug with the 8051 simulator, you can add an extra post link step to build a standalone
8051 project and create an absolute ELF file that you can debug. To do this:

1.
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From the Project menu, select Properties for myproject.
The Properties dialog appears.

Select C/C++ Build » Settings.

Open the Build Steps tab.

Add the following command line to the Command field under Post-build steps:

"${ PRODDI R}/ bi n/ | k51" -dtc49x.lsl -M-o0 ${PRQJ}.el f ${PRAI}. out --core=npe: xc800
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5. Click Apply and Close.

Debugging an ARC project
In order to debug an ARC project, follow the steps below.

1. Make sure the Synopsys ARC® nSIM Instruction Set Simulator is present. This simulator is not part
of the SmartCode product, you need to order it separately from Synopsys®. Then copy the 64-bit
Windows file | i bsi m dl | to the following directory:

<install ation-dir>\eclipse\plugins\comtasking.arc. debug. wi n32. x86_64_1.4.0.0\carc\bin

2. Create an ARC project (for example, mypr oj ect ), as explained above.
3. Build the ARC project.
This results in an ELF file (. el ).

4. Create a debug configuration for the ARC project with the Synopsys nSIM Simulator as target, if you
have not already done so when creating the project. See Section 4.1.2, Create a Debug Configuration.

5. Start the debugger, as explained in Section 4.2, Start a Debug Session.

Note that when you have a project reference from a TriCore project to the ARC project, the ARC project
is built automatically when you build the TriCore project.

4.1.2. Create a Debug Configuration

Before you can debug a project, you need a Debug launch configuration. Such a configuration, identified
by a name, contains all information about the debug project: which debugger is used, which project is
used, which binary debug file is used, which perspective is used, ... and so forth.

You can create a launch configuration when you create a new project with the New C/C++ Project wizard.
In Section 3.1, Create a Project we created one for the TASKING simulator. At any time you can change
this configuration.

For details on creating or changing a debug configuration, refer to section Creating a Customized Debug
Configuration in Chapter Using the Debugger of the TASKING SmartCode - TriCore User Guide.

4.1.3. Setting TASKING winIDEA Preferences
In order to select the winIDEA installation of your choice, follow the steps below.
1. From the Window menu, select Preferences.

The Preferences dialog appears.

2. Select TASKING winIDEA.
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3. Select your preference for the desired winIDEA setup. Select Use embedded installation to use
the winIDEA that is already embedded in the product, or select Use this installation to use the
winIDEA installation in your system.

4. Click Apply and Close.

4.2. Start a Debug Session

1. From the Debug menu select Debug project.

Alternatively you can click the % button in the main toolbar.

The TASKING Debug perspective is associated with the TASKING C/C++ Debugger. Because the
TASKING C/C++ perspective is still active, Eclipse asks to open the TASKING Debug perspective.

Please note that the TASKING winIDEA session can be viewed by switching to the CDT Debug
perspective.

2. Optionally, enable the option Remember my decision and click Switch.

The debug session is launched. This may take a few seconds.

workspace_smartcode _vx.y7z - myproject/myproject.c - SmartCode Eclipse IDE veyrz - o x
File Edit Source Refactor Navigate Search Project Debug Window Help
mifhd | @i @y~ Bin|MS 0 @ N DD R | @i ¥ -gl-oForo-m a gl B
45 Debug X = g = B ||®= Veriables X . % Breakpoin| " Expressio = B || Registers X HE|riet 8§ = O
~ %5 myproject [TASKING C/C++ Debugger] CEl= % || Name Value Description ~
~ I;\CTi‘vE 1.dx[|.;cs:;<]t;zn sasdwé.;\amr [taskingdebugg | . pe Value #4 ADC ADC
v o Threa uspende
= 4 0o i signed int Cannot read vari A ASCLIN ASCLIN
= main() at myproject.c:3 (x80048cab 444 CBCU SBCU CBCU_SBCUTEC.
= start( at cstart.c:961 0xE004842 X4 Css — Bs
#4 CLOCK CLOCK v
< >
< >
[¢ myproject.c X = B |[& Disassembly X . 5 Outline =8
#include <stdic.h> ~ Enter locatien here “ | 8 wlE @| e 8
J - int main( void ) » 00B00ABOBER43ea6: sub.a . ?P,MK§ -~
6 for (i=1; ic=3; i++)
int i 200000008004 5cas8 mov dis, #ex1
: B0BDBODDEOBABeas @ mov.a als, #0x2
for (i=1; i<=3; it+ i %
or (i=1; i¢-3; 1+) 8 printf( "%d\n",i );
printf( "d\n",1 ) 0000000080048eac:  St.w [sp],di1s
o 0000060080048cac:  lea a4, 0x50000004
printf( "Hello world, " )3 EEBBEBBBEBBAEEI:Q: (E]éil. (im1 Ezig%Fli?;SBMSEfQ)
printf( "this is \n" )3 . T e
prime( - sl M3 ); rovmrnisce:wd dinid
intE( "deb Jent ebs:  loop als, exgoedseac
Y printf( "debugging example.\n” )3 16 printf( "Hello world, " )
v 28800008080843cba : movh.a a4, #0x8005 A
B Console X & Tasks SRR MBS = 00 Memory X | BSl 5-3 =0
Debug [myproject] Menitors .
Communication: TSIM1 Simulator -~
Debug Instrument Module: tsimlép_e
Starting Debugger. .
Launching configuration: myproject
Loading 'C:\Users\name\workspace_smartcode_vx.yrz\myproject\Debug\mypr
< >
Writable Smart Insert 3:1:22

» The Debug view shows your running application. Because of the settings in the debug configuration,
execution has suspended at the first instruction in the function mai n() .

» The Editor view shows the C source files of your application and shows the line where the execution
has suspended.
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» The Variables view shows the variables in your application; in this case i nt i .

4.3. Stepping through the Application

At this moment your application is executing but suspended on the function mai n() . This means the C
startup code has been executed already. From this point, you can step through your application while
inspecting what happens.

1.

From the Debug menu, select Step Over, or press F6, or click on the Step Over button (%) in the
Debug view.

The highlight in the Edit view moves to the next statement.

Press F6 again.

The highlight in the Edit view moves to the next statement.

In the Variables view, you can inspect the value of the variable i . It is now set to 1.
Press F6 again.

The pri ntf statement has been executed now. The bottom area of your workbench now shows a
new view: FSS # 1 - myproject.

FSS stands for File System Simulation. The FSS view simulates the input and output to and from
the simulator when you are debugging. The value of i nt i is printed and sent to the FSS view for
output.

To clear the FSS view, right-click in the view and select Clear.
To restart your application, from the Debug menu, select Restart (%5).

Step further through your application.

Watch the value of i nt i in the Variables view and observe the output in the FSS view. The output
is only flushed after a newline (\ n)!

When you debug your application in an interrupt enabled environment, it might be useful to enable

Interrupt aware stepping (9°‘>). This prevents stepping into an interrupt handler when an interrupt
occurs.

4.4. Setting and Removing Breakpoints

Instead of stepping, you can set breakpoints to suspended the application at a certain point.
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A breakpoint is set on an executable line of a program. If a breakpoint is enabled during debugging, the
execution suspends before that line of code executes.

Add breakpoints
To add a breakpoint:

» Double-click the marker bar located in the left margin of the C/C++ Editor next to the line of code where
you want to add a breakpoint.

Adot ® is displayed in the marker bar and in the Breakpoints view, along with the name of the associated
file. When the breakpoint is actually set, a check mark « appears in front of the dot.

Disable breakpoints

You can disable a breakpoint or completely remove it. To disable a breakpoint, do one of the following:
* In the Breakpoints view, disable a breakpoint by clearing the check box.

* In the Editor view, right-click on a breakpoint dot in the margin and select Disable Breakpoint.

The blue breakpoint dot turns white.

Remove breakpoints

To completely remove the breakpoint, do one of the following:

* In the Breakpoints view, right-click on a breakpoint and select Remove.

« In the Editor view, right-click on a breakpoint dot in the margin and select Toggle Breakpoint.
* In the Editor view, double-click on a breakpoint.

The blue breakpoint dot disappears.

Example

With the techniques described above:

1. Setaline breakpoint on the code lineprintf( "a small %dst\n",i-3 );.
2. Clear the FSS view.

3. Restart your application.

The application suspends when entering the main() function because this was defined in the Debug
configuration.

4. To resume execution, from the Debug menu, select Resume, or press F8, or click on the Resume
button (IF).,
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The application suspends execution, before this line is executed. The FSS view now shows:

1
2
3
Hello world, this is

5. Resume execution again to finish execution.

Note that though the application has finished execution, it has not been terminated yet. Your debug
session is still active.

4.5. Reload Current Application

When your application had changed, for example because you solved a bug, you can reload the application
in the debugger without restarting it.

1. Make the necessary changes in your source.
2. Rebuild your application (%),

3. Click on the Reload current application button (o'ﬁ%).
The new application is loaded in the debugger.
You can also instruct the debugger to reload the application automatically after a rebuild of the application.
1. From the Window menu, select Preferences.
The Preferences dialog appears.
2. Select TASKING » Debugger Miscellaneous.

3. Selectyour preference for Re-download after rebuilding project. Select Always to always download
the new built application, or select Never, or select Prompt to get a question each time after rebuilding
the project.

4. Click Apply and Close.

4.6. End a Debug Session
To end the debug session:

1. From the Debug menu select Terminate or click on the Terminate button (H),

2. Toremove the debug session from the Debug view, right-click on the debug session and select

Remove All Terminated or click on the Remove All Terminated Launches button (“%) in the Debug
view.
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4.7. Multiple Debug Sessions

It is possible to run multiple debug sessions. To do so, just repeat the steps for starting a debug session.
First make sure that you have terminated all debug sessions.

1. From the Window menu, select Preferences.
The Preferences dialog appears.
2. Select TASKING » Debugger Start-up.
3. Enable the option Allow multiple simultaneous debug sessions.

4. Select what you want to happen When trying to start another debug session for the same
configuration. Select Re-download to download the absolute file again, or select Start new session,
or select Prompt to get a question each time you try to start a new session.

5. Click Apply and Close.

6. From the Debug menu, select Debug Configurations...
The Debug Configurations dialog appears.

7. Select the debug configuration mypr oj ect . si mul at or and click on the Debug button.
The debug session launches.

8. Repeat steps 1 and 2, but in step 2 choose nypr oj ect .

There are now two debug sessions for the same application. In case you have multiple projects, you can
make dedicated debug configurations for them. You can use these debug configurations to run multiple
debug sessions at the same time.

Each session uses its own FSS view for output. In the Debug view you can select the debug session (or
file in the debug session) for which you want to inspect, for example, the value of its variables in the
Variables view.
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